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E M8 O 6 2-phase Digital Stepper Drive

24-80V, 0.35-6A, Sensorless Stall Detection, Pre-Matching Motor

Sensorless stall detection eliminates cost of feedback devices and time of cable connection
Super-low motor noise offers excellent quietness
User password protection prevents others from copying your drive configurations

Anti-Resonance optimizes torque and nulls mid-range instability
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Self-test and Auto-configuration technology offers optimum performance for different

motors

O

Multi-stepping allows a low resolution input to produce a higher microstep output for
smoother system performance

Options to set output current and microstep relolutions via DIP switch or software
Command input of PUL/DIR, Microstep from 1 to 512

Automatic idle-current reduction and reduction rate is software configurable

Over-current, over-voltage, short-circuit protections besides sensorless stall detection
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Fault out prevents damages to your machines or the materials

Descriptions

By implementing the latest motion control technologies, Leadshine's EM series DSP-based stepper drives deliver excellent performance
not available before. Unique features of sensorless stall detection, extra smoothness and excellent high speed performance make EM
stepper drives deliver servo-like performance at the cost of stepper drives. They are capable of delivering high performance without
damages to your machines or the materials. Leadshine EM series stepper drives are able to drive 2-phase or 3-phase stepper motors from

NEMAS to NEMA42.

Applications

EMS806 stepper drives are suitable for driving a wide range of 2-phase stepper motors, from NEMA frame size 23 to 42. Typical

applications include CNC routers, laser cutters, laser markers, medical equipments, X-Y tables, measurement equipments, etc.
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Specifications

Electrical Specifications

Parameter Min Typical Max Unit
Input Voltage 24 68 80 VDC
Pulse Input Frequency 0 - 200 kHz
Logic Signal Current 7 10 16 mA
Isolation Resistance 500 - - MQ

Operating Environment

Cooling Natural Cooling or Forced cooling
Environment Avoid dust, oil fog and corrosive gases
Storage Temperature -20°C —65°C(-4°F — 149°F)
Operating Environment Ambient Temperature 0°C = 50°C O2°F — 122°F)
Humidity 40%RH — 90%RH
Operating Temperature (Heat Sink) 70°C (158°F) Max
Vibration 10-55Hz, 0.15mm/s
Storage Temperature -20°C — 65°C (-4°F — 149°F)
Weight 560g (19.750z)

Mechanical Specifications
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Protection Indications

The green indicator turns on when power-up. When drive protection is activated, the red LED blinks periodicity to indicate the error type

Priority Time(s) of Blink Sequence wave of RED LED Description
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Connectors and Pin Assignment

The EM806 has two connectors, connector for control signals connections, and connector for power and motor connections.

1st 1 Over-current protection

I
1

2nd 2 Over-voltage protection

3rd 5 Motor Stall Protection

Control Signal Connector

Pin Name I/O Description

1 PULA+ I Pulse Signal: This input represents pulse signal, each rising or falling edge active. 4-5V when PUL-HIGH,
0-0.5V when PUL-LOW. For reliable response, pulse width should be longer than 2.5us. Series connect
resistors for current-limiting when +12V or +24V used. The same as DIR and ENA signal.

2 PUL- 1
Direction Signal: This signal has low/high voltage levels, representing two directions of motor rotation. For

& LLLLESS ! reliable motion response, DIR signal should be ahead of PUL signal by 5us at least. 4-5V when DIR-HIGH,

0-0.5V when DIR-LOW. Please note that rotation direction is also related to motor-driver wiring match.

4 DIR- I Exchanging the connection of two wires for a coil to the driver will reverse motion direction. The direction

signal’s polarity is software configurable.

Enable Signal: This signal is used for enabling/disabling the driver. In default, high level (NPN control

signal) for enabling the driver and low level for disabling the driver. Usually left UNCONNECTED

5 ENA+ 1

(ENABLED). Please note that PNP and Differential control signals are on the contrary, namely Low level for

v O ! enabling. The active level of ENA signal is software configurable.

Fault Signal: OC output signal, active when one of the following protection is activated: over-voltage, over
! FLTE o current, short circuit and stall-error. This port can sink or source 20mA current at 24V. In default, the
resistance between FLT+ and FLT- is low impedance in normal operation and become high when EM806
8 FLT- 0 goes into error. The active level of fault signal is software configurable. See EM drives software operational

manual for more detail.
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Power and Motor Connector

Pin  Name o Description
1 A+ (0] Motor Phase A+
2 A- O Motor Phase A-
3 B+ (0] Motor Phase B+
4 B- O Motor Phase B-

Power Supply Input (Positive), 24-72VDC recommended, leaving rooms for voltage fluctuation and

back-EMF.
6 GND GND Power Ground (Negative)

(9}
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RS232 Communication Port
It is used to configure the peak current, microstep, active level, current loop parameters and anti-resonance parameters. See EM driver’s

software operational manual for more information.

RS232 Communication Port

Pin Name o Description
1 NC Not connected.
2 +5V O +5V power only for STU (Simple Tuning Unit).
3 TxD RS232 transmit.
4 GND GND  Ground.
5 RxD RS232 receive.
6 NC - Not connected.

DIP Switch Settings

Dynamic Current

Peak RMS SW1 SW2 SW3
Default Default on on on
2.7A 1.93A of on on
3.6A 2.57A on off on
4.6A 3.29A off off on
5.5A 3.93A on on off
6.4A 4.57A of on off
7.3A 5.21A on off off
8.2A 5.86A off off off

Note: Due to motor inductance, the actual current in the coil may be smaller than the dynamic current setting, particularly under high speed condition.
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Idle-Current

SW3 determines whether the idle current is reduced automatic or remains the same as the dynamic current setting.

ON OFF
The motor idle current reduces automatically The motor idle current is the same as the
Sw4 when there is no pulse applied to EM806. dynamic current when there is no pulse applied
to EM806.

Auto-Configuration

Switch SW4 two times in two seconds to auto-configure the drive’s current loop parameter. That is, OFF-ON-OFF or ON-OFF-ON.
During Auto-configuration, motor parameters are identified and the EM drive's current loop parameters are calculated automatically. The

motor shaft will vibrate a little during the process of Auto-configuration which takes about 1 to 3 seconds.
Motor Selection and Pre-matching Leadshine Motor

There is a rotation switch used for the motor selection.

Matching Motor Connection Code Description

STHS09 Parallel 0
57HS13 Parallel 1
57THS22 Parallel 2
86HS35 Parallel 3
86HS45 Parallel - 4
86HS85 Parallel 5 Select pre-matching Leadshine stepper motor. EM806 has
57HS09 Series 6 been tuned for these motors.
57HS13 Series 7
5THS22 Series 8
86HS35 Series 9
86HS45 Series A
86HS85 Series B
Custom1 - C

Select non-Leadshine motor. EM806 needs tuning either
Custom2 - D )

by Auto-configuration or the PC software. There are up to
Custom3 - E . )

four custom positions for customer selection.
Custom4 - F

Pulse Active Edge
ON OFF
SW8 Active rising edge of pulse. Active falling edge of pulse
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Microstep Resolution

Steps/Revolution SW5 SWe SW7

Software Configured (Default 200) on on on
400 off on on

800 on off on

1600 off off on

3200 on on off

6400 off on off

12800 on off off

25600 off off off

Speed Torque Curve for Pre-matching Leadshine Motor
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Typical Connections

Differential Control Signal NPN Control Signal
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RJ11 Connector for RS232 Communication

RJ11 Connector

Applied To:

Stepper Drive:

DM432C, DM442, DM556, DM856, 3DM683, AM882, DM1182, DM2282
Servo Drive:

DCS810, DCS810S, ACS306, ACS606, ACS806

Pin Signal Description 110
1 NC - -
2 +5V +5V power only for STU, left it unconnected when connect to a PC serial port O
3 TxD RS232 transmit. O
4 GND Ground. GND
5 RxD RS232 receive. I
6 NC - -

2. Cable connections to a PC serial port (Male DB9)
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Software Operational Manual
for EM Series Stepper Drives
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Introduction

The ProTuner is a software tool designed to configure and tune the Leadshine EM series digital stepper drives include EM402, EM503,
EM705 and EM806. The user can configure the drive’s output current, micro step, electronic damping, command type, tune the current

loop and adjust the anti-resonance parameters in this software.

Workspace

Menu

Toolbar

Properties

Window

Menus and Toolbar

Menus and toolbars are at the top of the workspace. You can click menu bar to view pull-down menu. The toolbar below offers the most

frequency used commands.
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Leadshine Home Page Click to visit Leadshine Home Page

Menu Pull Down Toolbar Function
Open @‘ Open a file
Save B Save a file
File ->
Save As - Save as a file
Close - Close the current file
Exit - Exit from the software
Connect To Drive - Connect to drive
Current Loop M Configure current loop parameters Kp and Ki.
) Set drive properties like output current, Micro Step,
Properties ; 1 ol ) o]
. type, tr t .
Drive > command type, electronic damping and active edge
Configure the built-in pulse generator which is used
Build-in Generator I%
for anti-resonance tuning and self-test.
Download to Drive - Download data to drive
Reset Drive - Reset drive to factory setting
Error Log | Check the drive error log.
Tools->
PIN Management - Change the drive’s PIN
Hardware Manual on Web - Click to view EM drives hardware installation manual.
Software Manual on Web - Click to view EM drives software operational manual.
Help->

About Leadshine ProTuner Software Information
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Using the Software

Opening a file

If you want to load the configuration data from a file in the PC, click on the File->Open. The parameters in the software’s workspace

will be updated. The file name will appear in the tile bar.

File Name

Save a file

Click Drive->Save to save the data of current workspace to the open file. If there is no file opened, the Save Dialog appears and you can

type in the file name then save it.

Save as a file

Click Drive->Save As to save the data in current workspace to a file and rename it.

Close

Click Drive->Close to close the current file.

Connecting Drive

Connect to Drive window appears every time you open ProTuner. You can also open it by clicking Drive->Connect any time. Select
the serial port and click on the Connect button. The software will try to connect to the drive and read the settings. It may take several

minutes. Please wait.
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Before connecting the drive, please make sure:
1) The RS232 cable .has been connected between the drive and PC serial port.
2) Power has been applied to the drive and the green LED is turned on.

The motor is no need to connect to the drive if you just want to change the parameters but not tuning.

P>

A Do not connect or disconnect serial cable when drive is powered on. The drive’s communication circuit may be damaged.

Current Loop Tuning Window

Red Curve:
Target Current of Step Test

~

Green Curve:

Actual Current of Step Test

Click Drive->Current Loop to open the current loop tuning window. You can adjust the Kp (proportional gain) and Ki (integral gain) in

this window. These parameters should be tuned before normal operation.

Item Description Range

Increase Kp to make current rise fast. Proportional Gain determines the

response of the drive to current setting command. Low Proportional

Kp Gain provides a stable system (doesn’t oscillate), has low stiffness, and
(Proportional Gain) large current error, causing poor performances in tracking current 170995

setting command in each step. Too large Proportional Gain values will

cause oscillations and unstable systems.
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Ki
(Integral Gain)

Test Current

Manual Tuning

Self-test and

Auto-configuration

Adjust Ki to reduce the steady error. Integral Gain helps the drive to
overcome static current errors. A low or zero value for the Integral Gain
may have current errors at rest. Increasing the Integral Gain can reduce
the error. If the Integral Gain is too large, the systems may “hunt”

(oscillate) about the desired position.

The current amplitude for the step response. Let this value not exceed

the maximum output current of the drive.

Enter Kp and Ki and click this button to activate the test. A target curve
(red) and an actual curve (green) will be displayed on the screen for user

analysis.

Click this button to activate self-test and auto-configuration. The Kp

and Ki will be tuned automatically.

Properties - Input/Output Settings

165535

EM402: 0.5 -2.2A
EM503: 0.5 -4.2A
EM705:: 0.5 -7.0A
EM806:: 0.5 - 8.2A

Click Drive->Properties to open the Properties window. In the Input/Output Settings Tab, the user can set Output Current, Micro

Step, Idle Current, Electronic Damping, Pulse Active Edge and Command Type.

1. DIP switch must be in Default mode (SW1, 2 for EM402 and SW1, 2, 3 for the others) to allow current change.
& 2. DIP switch must be in Default mode (SW4, 5 for EM402, SW5, 6, 7, 8 for EM503 and EM705, SWS5, 6, 7 for
EMS806) to allow Micro Step change.
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Item

Output Current

Micro Step

Idle Current

Idle Start Time

Electronic Damping

Command Type

Active Edge

Direction Change

Alarm Signal

Apply
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Description

Drive’s output current for the motor. It should be less than 1.4
times of the motor’s RMS current/phase.

Note: The DIP switch setting must be in default mode as
follows to be configured by software.

EM402: SWI1=o0n, SW2=o0n

EMS503, EM705, EM806: SW1 =on, SW2 = on, SW3 =on

Drive’s Micro Step setting for the motor.

Note: The DIP switch setting must be in Default mode as
follows to be configured by software.

EM402: SW4=on, SW5 = on

EMS503, EM705: SW5 =on, SW6 = on, SW7 = on, SW8=on
EM806: SW5 =on, SW6 = on, SW7 = on

Idle current at motor stop. The drive goes into idle state when
there is no pulse applied to it and the DIP SW3 (EM402), SW4
(The others) is set to OFF.

The time when there is no pulse applied to the drive. The drive

goes into idle state after this time.

Adjust this parameter to improve the drive’s high speed

performance. The optimal value depends on the system.

Command Type or pulse mode of control signal. Select
PUL/DIR or CW/CCW according to command type of motion
controller. PUL/DIR means pulse and direction mode;
CW/CCW means double pulses mode. (Note: The EM402 and
EMS806 only support step & direction command.)

Pulse active edge. The motor shaft moves one micro step every

active edge.

Change the motor direction. It is only active in PUL/DIR
command mode. Please note that the actual direction is also

related to the motor coil connection.

Set active impedance for the alarm (fault) signal. Active High
means high output impedance for drive error and Active Low
means low output impedance for driver error. (Note: The
Alarm Signal of the EM503 and EM705 can not be configured,
fixed at Active Low.)

Apply Button. Click this button to apply all the changes.

Range

EM402: 0.07-2.2A
EM503: 0.21-4.2A
EM705: 0.35-7.0A
EM806: 0.35-8.2A

1-512

10%-100%

1-58

1-6000

PUL/DIR
CW/CCW

Rising

/Following

(High)Positive
/(Low)Negative

Active Low
/Active High
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Properties - Enable/Disable Features

This window offers options of enabling phase error detection, motor stall detection and pulse filter. You can also set the active signal of

the enable signal and use it for drive reset to clear the error.

Item Description

Check it to enable phase error detection which is activated when motor
Phase Error Detection connection is wrong or one of the motor lead is disconnected. The alarm/fault

output will be active if it is enabled.

Check it to enable motor stall detection without sensor. The alarm/fault output
Sensorless Stall Detection
will be active if it is enabled.

Check it to let the enable signal to reset the drive which is in error state. The

ENA to Reset the Drive
drive will restart and all the error will be clear.
ENA Active High Check it to set the active high for ENABLE signal.
Pulse Filter Enable Check it to enable the pulse filter which smooth the command input.

(021) 33913364 - 33951660

(021) 33985603




114 1)

OBC Oskoyi Ballbearing

Oskoyi Ballbearing Company

Built-in Controller for Self-test

You can adjust the anti-resonance parameters in this window. The built-in controller can be used for anti-resonance tuning and self test.
Item Description Range
The 1st Resonance Area It is usually between 0.6 to 1.2 RPS. -

Amplitude adjustment for the 1% anti-resonance area. The user can enter a
Amplitude 1 value directly in the text box or move the slider bar back and forth to get 0-3500

an optimum value.

Phase adjustment for the 1% anti-resonance area. The user can enter a
Phase 1 value directly in the text box or move the slider bar back and forth to get 0- 1608

an optimum value.
The 2nd Resonance Area It is usually between 1.2 to 2.4 RPS. -

Amplitude adjustment for the 2™ anti-resonance area. The user can enter a
Amplitude 2 value directly in the text box or move the slider bar back and forth to get 0-3500

an optimum value.
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Phase 2

The 3rd Resonance Area

Amplitude 3

Phase 3

Speed

Acceleration

Interval Time

Repeat

Motor Moving Direction

Start
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Phase adjustment for the 2" anti-resonance area. The user can enter a
value directly in the text box or move the slider bar back and forth to get

an optimum value.
It is usually between 2.4 to 4.8 RPS.

Amplitude adjustment for the 3™ anti-resonance area. The user can enter a
value directly in the text box or move the slider bar back and forth to get

an optimum value.

Phase adjustment for the 3™ anti-resonance area. The user can enter a
value directly in the text box or move the slider bar back and forth to get

an optimum value.

Display the current speed when you move the slider.
Acceleration of Built-in Controller.

Interval between the positive and negative move.
Repeat times.

If it is positive, the motor moves only in positive direction. If it is
positive and negative, the motor moves in both positive and negative

direction.

Click to start the motion.

0-1608

0-256

0-256

0-20 RPS

1-65535

1-65535

1-65535
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Error Log Window

Click Tool->Error Log to open the error log window. This window shows both the present status of each error event and their history.

Item Description
Over Current The motor coil current exceeds the output limit of the drive.
Over Voltage The input voltage exceeds the input limit of the drive.
Phase Error Wrong motor coil connection or one of the motor lead is disconnected.
Stall The motor has been stalled.
Clear All Errors Clear the error log.

PIN Management Window

Every EM drive has a 4-digit PIN (Personal Identification Number). The default PIN is 0000. If you don’t want the drive’s configuration
from read by others, set or change the PIN number in this window. Next time the software communicates with the drive, it requires the
operator to enter the PIN number. If you forget the PIN, the only way to communicate with the drive again is resetting the drive by

clicking Drive->Rreset Drive. The PIN will be 0000 again and all the data is reset to factory setting.
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Configuring the Drive

If it is the first time setup, you can follow the steps below to configure the drive.

1)  Set Input/Output parameters like output current, Micro Step and command type according to the motor and application.
2)  Tune the current loop parameters with the connected motor.

3) Tune the anti-resonance parameters if necessary.

4)  Adjust the electronic damping when the high speed performance is not good.

A The motor must be connected to the drive before trying to configure the drive.

Set Input/Output Parameters

Click Drive->Properties to open the Property window. You can set the Output Current, Micro Step and Command Type.

In most of the application, it is required to set only the output current, Micro Step and Command. Usually, the motor manufacturer states

the RMS (root mean square) current in datasheet. Please refer to the hardware installation manual for how to set the output current.

1. DIP switch must be in Default mode (SW1, 2, for EM402 and SW1, 2, 3 for the others) to allow current change.

2. DIP switch must be in Default mode (SW4, 5 for EM402, SWS5, 6, 7, 8 for EM503 and EM705, SWS5, 6, 7 for
A EM&806) to allow Micro Step change.

3. The EM402 and EM806 only support step & direction command.

High resolution Micro Step makes the motor move more smoothly. Low Micro Step resolution reduces the high frequency requirement

to the controller. See the EM drives hardware installation manual for more information for how to select the Micro Step.
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Current Loop Tuning

The current loop parameter needs to be tuned before normal for optimize responses with different motors. Otherwise motor will be

easily stalled or howls at power-up. Below is the tuning process of EM705 for a NEMA 23 motor with 24VDC supply voltage.

g Before trying to tune the current loop parameters, select “custom” in the motor selection table for the rotation switch.

Please note that change of motor requires re-power of drive.

Step 1: Set Test Current 0.5 and start the tuning with small Kp and “zero” Ki. Here we set Kp=500 and Ki=1.

Initial Value
Kp =500
Ki=1

Step 2: Click the Test button and the plot window will show two curves. The red curve is target current and the green curve is actual

current. There is large gap between them in the scope. It indicates that a large Kp needs to be introduced.

Start Test:
Kp =500
Ki=1
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Step 3: Increase Kp to 1000 and click Start. The gap between target value and actual value is smaller but a higher Kp is still needed.

t Proportional Gain:
Kp = 1000
Ki=1

Step 3: Give Kp 2000, 3000, 4000 and click Manual Tuning, respectively. The green curve is getting more and more close to the red
curve. Over-shoot is obvious when we increase Kp to 4000. It indicates that you need to stop increasing Kp and back off. Our purpose is

to make the green curve (the actual current) a little higher than the red curve (the target). So we decrease Kp to 3700 until the actual

value is exactly over the target value.

t  Proportional Gain:
Kp =2000
Ki=1
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t Proportional Gain:
Kp = 3000
Ki=1

t Proportional Gain:
Kp =4000
Over-Shoot
Ki=1

I Proportional Gain:
Kp =3700
Ki=1
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Step 4: Now the Kp is relatively good enough. But there is still gap between the green curve and the red curve when we use the mouse

to zoom in the green curve. So we need to introduce Ki to reduce the “gap” or steady error at the constant part. It follows the same

procedure as Kp. High Ki causes big vibration, system lag and makes the performance worse. The following figures show how to tune

the integral gain.

7

Drag a triangle to zoom in

Zero Integral Gain:
Kp =3700
Ki=1
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t Integral Gain:
Kp =3700
Ki=200

t Integral Gain:
Kp =3700
Ki=400

Step 5: The current loop tuning is basically finished. You can continue to adjust Kp and Ki for better performance. Now the updated
Kp and Ki is just stored in the driver’s RAM. They will be lost when we power off the driver. Don’t forget to click Drive->Download
To Drive to store the changed value to the drive’s EEPROM.
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Further Adjustment:
Kp =3500
Ki=300

Commect to Driwe

Current Loop

P : Save all the changes to the drive’s
roperties

Build-in Generator non-violated nonvolatile memory.

You need to close the current tuning
w\‘ window firstly.

eset Iriwve

Q (021) 33913364 - 33951660 : wsli ¢f
(021) 33985603 : uuSS PR




114 1)

OBC Oskoyi Ballbearing

Oskoyi Ballbearing Company

Anti-resonance Tuning

Stepper motors are highly resonant, which results in vibration and ringing. The ringing utilizes a large fraction of the motor's available
torque — thereby wasting performance. Furthermore, at mid-range velocities, the resonance can become so severe that the motor looses
synchronization and stalls. The EM drive provides robust anti-resonance control to stop the vibrations and maintain equilibrium. This
feature requires that the drive be configured with respect to the total inertia in the system. If set improperly, the effectiveness of the

feature may be diminished.

1. For most of the application, it is not needed to tune EM drive anti-resonance parameters. We only recommend the
A advance user to use this function as it is a boring process.

2. In most of the case, only the tuning of the 1% and 2™ anti-resonance area has obvious effect.

Step 1: Start the motion test by clicking Start/Stop button. Find a resonance speed by slightly moving the slider bar of internal pulse

generator back and forth. You can also use the arrow keys to adjust the speed precisely.

Step 2: Run the motor at the resonance speed and verify the motor smoothness. You may find a better smoothing value by slightly
moving the slider bars of Amplitude and Phase back and forth.

It is very important to make the Amplitude and Phase adjustments at the proper test speeds with an unloaded motor. Running at an
incorrect test speed will not excite the motor at its peak resonance, making it more difficult to find proper adjustment values. Optimum

Amplitude and Phase values may be a little different between running the tests with an unloaded motor and a load motor.

Step 3: Keep the motor running at the resonance speed and verify the motor smoothness. You may find a better smoothing value by
slightly moving the slider bars of Amplitude and Phase back and forth. If the motor speed is 0.6-1.2RPS, you should tune the Amplitude

and Phase at the 1% resonance area. The 2" resonance area is 1.2-2.4 RPS and the 3" resonance area is 2.4 4.8 RPS.

For example, we find a resonance speed at 0.98 rps. We begin to move the Amp1 slider forth and the motor vibration and noise became
lower and lower. Finally we find the move is the smoothest when Amplitude 1 is 3300. The motor vibration and noise increase if
Amplitude 1 exceeds 3300. Then we follow the same procedure to search the best point for Phase 1. See Figure 26. Anti-resonance

tuning is done.

Step 4: Click Drive->Download To Drive to save all the parameters to EM drive’s nonvolatile memory.

Adjusting Electronic Damping

The factory setting for the electronic damping is 1000. If the motor is easily stalled and generates odd noise at middle speed, you can try

other values such as 500, 1500, 2000, 2500.

D site : www.10BC.com
R4 Email : Borhan772000@yahoo.com
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